This article will help you troubleshoot the issue of not receiving WhatsApp messages.
Problem
After integrating your WhatsApp account with Comm100, you are unable to receive messages.
Cause
There are two possible reasons for the issue you are experiencing:
- Your Twilio number is not enabled for WhatsApp.
- The Webhook URL you are using is not correct.
Solution
1. Log in to your Twilio account.
2. Check-in Twilio > Messaging > Senders > WhatsApp senders that your account has been approved.
3. If your account is already approved, check the Webhook URL for incoming messages.
Modify the Webhook URL as “https://messagingproxy.comm100.io/messagingproxy/mmm61yylzxl5va6i/whatsapp/whatsapp:[phonenumber]”.
Use your account number in place of [phonenumber].
4. Click Save.
If you continue experiencing the issue, chat with us.